Random Magic Mouse Disconnects

The new 2018 Mac Mini was released and I decided I needed to update my aging system.  Previously, I was using a Macbook Air which I still love.  Once I got the new  Mini set up I started using the Magic Mouse I had been using with the Air.  I started having issues almost immediately.  Sometimes it would just disconnect and then after some period of time it would reconnect.  Other times it would get “ratty” – the mouse would start lagging, etc.  It would almost always just disconnect if I had stopped using it for a bit (when typing for example).  I connected the mouse back to my Air and it worked perfectly.  That rules out the mouse as being the problem, so I started looking on the web for solutions.  Certainly, somebody had a solution for this.  Not so.  To my surprise, this is not an uncommon problem and goes back many years.

I found one particular entry that had a large number of possible solutions that had not worked for them and they didn’t work for me either.  Since my Mini was brand new and I had purchased AppleCare for it, I broke down and called the help line.  I talked with them for a while and was finally prompted to reinstall the operating system.  This seemed odd to me since the Mini was like this right out of the box, but I went along with the suggestion.  After finishing that, I found the problem still was happening.

I also have an old Microsoft mouse that uses an RF connection vs. a bluetooth connection.  I found that when the Magic Mouse started to get “ratty” if I switched on the Microsoft mouse, used it to disconnect and reconnect the Magic Mouse it would work again as is should for while.  I put up with this for a few days but it was becoming an issue when I was coding.  It would break my train of thought and became very distracting.  So back to the web.

One of the things I read was about is what I’ll call “signal conflict”.  I read that the mouse broadcasts on the 2.4GHz band.  My router does both 2.4GHz and 5.0GHz.  I find that the 2.4GHz has greater range in my house, while the 5.0GHz has faster through-put (if I get a good connection).  We do a lot of streaming in the living room upstairs so most everything is connected to the 2.4GHz side of the router.  On a whim, I disconnected the Mini from the 2.4GHZ side and connected it to the 5.0GHz side.  Lo and behold, my bluetooth mouse problems ceased.

My guess is I had a 2.4GHz conflict because both the router and the mouse were using the same channel.  I found this information on how change channels but decided if it’s working, don’t fix it.